[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[oss-security] [CVE-2019-12422] Apache Shiro weak cookie vulnerability



The Shiro team is pleased to announce the release of Apache Shiro version
1.4.2.

This security release contains 1 fix since the 1.4.1 release and is
available for Download now [1].

    CVE-2019-12422:
    Apache Shiro before 1.4.2, when using the default “remember me”
configuration,
    cookies could be susceptible to a padding attack.

Release binaries (.jars) are also available through Maven Central and
source bundles through Apache distribution mirrors.

For more information on Shiro, please read the documentation[2].

-The Apache Shiro Team

[1] http://shiro.apache.org/download.html
[2] http://shiro.apache.org/documentation.html