[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [jfw] Problem adding joomla/event to my project



If you're running `composer require matware-lab/jupgradenext` then you're trying to include that project into another parent project. For the sake of argument, lets say I ran that command on the help screen proxy app (joomla/help-site) and that's the parent. Even though matware-lab/jupgradenext says that it allows dev dependencies (and explicitly requires some), my parent app's minimum stability is set to stable even though it has dependencies to dev versions (but those are explicitly requested versus having my global configuration set to allow dev stability). Once I add the "minimum-stability": "dev" config to my composer.json file my parent project correctly resolves the dependencies.

So in your parent project's composer.json file, you need to set the minimum stability to dev before you can include it.

On Sun, Oct 16, 2016 at 4:46 PM, Matias Aguirre <fastslack AT gmail.com> wrote:
Do you mean matware-lab/jupgradenext? Or some other project included into composer.json?

El domingo, 16 de octubre de 2016, 13:58:11 (UTC-3), Michael Babker escribió:
It seems like the project you're trying to include that in isn't allowing you to include non-stable dependencies.

On Sun, Oct 16, 2016 at 11:51 AM, Matias Aguirre <fast... AT gmail.com> wrote:

I have a problem with joomla/event and joomla/date version and i cannot found the answer, maybe here someone has some idea. Note that i'm using the 2.0 version of both packages


Steps to reproduce the issue


$ composer require matware-lab/jupgradenext:dev-master


Expected result

Is expected that package matware-lag/jupgradenext install correctly


Actual result


./composer.json has been created Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for matware-lab/jupgradenext dev-master -> satisfiable by matware-lab/jupgradenext[dev-master]. - matware-lab/jupgradenext dev-master requires joomla/event 2.0.*@dev -> satisfiable by joomla/event[2.0.x-dev] but these conflict with your requirements or minimum-stability. Installation failed, deleting ./composer.json.


System information (as much as possible)


$ uname -a Linux escorpio 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux $ php -v PHP 7.0.11-2+deb.sury.org~trusty+2 (cli) ( NTS ) $ composer -version Composer version 1.2.1 2016-09-12 11:27:19


--
Framework source code: https://github.com/joomla-framework
Visit http://developer.joomla.org for more information about developing with Joomla!
---
You received this message because you are subscribed to the Google Groups "Joomla! Framework Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to joomla-dev-framework+unsubscribe AT googlegroups.com.
Visit this group at https://groups.google.com/group/joomla-dev-framework.

--
Framework source code: https://github.com/joomla-framework
Visit http://developer.joomla.org for more information about developing with Joomla!
---
You received this message because you are subscribed to the Google Groups "Joomla! Framework Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to joomla-dev-framework+unsubscribe AT googlegroups.com.
Visit this group at https://groups.google.com/group/joomla-dev-framework.

--
Framework source code: https://github.com/joomla-framework
Visit http://developer.joomla.org for more information about developing with Joomla!
---
You received this message because you are subscribed to the Google Groups "Joomla! Framework Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to joomla-dev-framework+unsubscribe AT googlegroups.com.
Visit this group at https://groups.google.com/group/joomla-dev-framework.