I'm not really thrilled by the direction the framework has been taking.
What sparked my post was seeing a suggestion to deprecte JFile and JFtp and replace them with some other package.
I took a look at the other package and I fully agree that it is much more flexible and would be a welcome addition.
However, the difference between a "Framework/Platform" and a "Collection of Packages" is that a framework provides for a common shared terminology.
Whether you call the primary execution task of a class, task, doTask, execute, run, main, or something else doesn't really matter. What matters is that as much as possible, the same term is used consistently.
As such, I disagree strongly with the idea of deprecating and removing many of the framework classes in favor of other packages. I would much rather see the framework augmented by those packages.
IE redesign JFile so it is merely a convenience wrapper around SomeOtherClass.
I want to stress, I am not saying what /SHOULD/ be done - I am voicing my opinion to ensure that I did voice it and it can be duly considered and dismissed. :-)